Beta Olive Charging Dock work-around #1 (soldering method)

Follow

Comments

107 comments

  • Gabriele Foddis

    Io sono daccordo con Ken Cheng

    0
    Comment actions Permalink
  • Rolland Rice

    Hey! I'm NOT doing THAT! Send me two (2) working docks STAT!

    1
    Comment actions Permalink
  • Rolland Rice

    Also, those little rubber(?) pieces that held the Olive in it's cradle are useless. One of my cradle's came off during shipping. When I open, it fell out and is lost. The only one left is the non-led side of the cradle which makes it nearly impossible to push the olive out of it's cradle. Are these little bits important to charging?

    1
    Comment actions Permalink
  • Gabriele Foddis

    Diciamo che i bit aiutano a tenere fissata l'oliva al cubo di ricarica.

    0
    Comment actions Permalink
  • Thoor Eriksson

    Dear Olive... This is unfortunate. I understand that this must come as a chock to you and to all of us. The best thing and the only thing to do is of course to send a new charger to everyone. 

     

    1
    Comment actions Permalink
  • Ken Cheng

    Thoor makes a good point. Not everyone is capable of opening the cube charger and replacing the battery if one were provided. Ultimately, replacing the charger is the only way to be sure everyone can truly beta-test the device.

    As for some commenting about the little rubber pieces, (i call them sugar crystals), they seem a touch too large, making pushing the Olive in and out of the charger very difficult. I actually pulled them off, initially to see if there were screws holding the charger together. I've since gorilla glued them back in place, but I'm thinking of sanding them to hold just a little less tight.

    2
    Comment actions Permalink
  • Rolland Rice

    I'm up for changing the 80¢ battery! Where is it located and what do I have to order?

    Will I break the bottom by pulling it out? Does it just snap out?

    0
    Comment actions Permalink
  • Gabriele Foddis

    Apri la scatola con un lama sottile, stacca il connettore della batteria, si trova su un lato. La batteria che devi acquistare è jp502030 3.7v 250mAh.

    https://m.alibaba.com/product/60663714957/3-7V-260Mah-Lithium-Polymer-Lipo.html?s=p&spm=a2706.7843667.1998817009.1

    0
    Comment actions Permalink
  • Rolland Rice

    Those batteries look like they're available on Amazon. Used in Quadcopters.

    0
    Comment actions Permalink
  • Gabriele Foddis

    Esatto proprio quelle

    0
    Comment actions Permalink
  • Sherman Quan

    The jumper works.  The charging light is glowing.  I lost the sad resistor in the process.  I have yet to check it out.  Sadly.  I do want a better fix (replacement).   

    0
    Comment actions Permalink
  • Kevin Fitzpatrick

    Well, I tried the battery route and it seems to be working. Images below.

    1. "Borrowed" one of my son's quad-copter batteries.  It was larger so it does not fit in the olive cradle. 
    2. Spliced the wires from the old battery to the new battery. 
    3. Cut a small slot in the cradle. 
    4. Plugged battery in. 
    5. Reassembled the cradle and tried the olive with and without charger. 
    6. LED on Olive flashes as it charges.




    1
    Comment actions Permalink
  • Sherman Quan

    I don't like how that I have to used a narrow object like a pencil or a pinkie to push the Olive out of its dock!

    This is a beta unit.  I think Olive Union owe us backers for a great final device. When all the bugs are worked out.  :-)

    0
    Comment actions Permalink
  • filmlawyer

    This work around worked for my olive charger. Olive LED lights and Bluetooth pairing did not work until after I was able to charge my olive. So far so good.

    2
    Comment actions Permalink
  • Henry Garcia

    Ton Weenk's "kick in the ass" method worked for me.  It was relatively easy and required no soldering or additional/replacement batteries.  Only tools I used were an x-acto blade and a 18650 battery charger (output 3.7V 500mA).  Here's how I did it:

    Pry open the base of the charger with the x-acto blade.

    Use the x-acto blade to unplug the battery connector from the pcb.

    Use the x-acto blade to pry under the small white tabs of the connector that hold in the terminals.

    Gently pull out the red and black battery terminals

    Connect the terminals to the 18650 charger (black to negative, red to positive).  I did this 3 times for about 10 seconds, making sure the battery was not overheating.

    Reinsert the terminals in the white connector (red wire on the outside), replace the battery and base, insert the Olive and watch the LED start to glow intermittently.  Using a rubber band to hold in the Olive since the small retention tab popped out, as others have experienced.  Good luck to all who want to give this a try!

    1
    Comment actions Permalink
  • Kevin Fitzpatrick

    Well, that was short lived. Had it fully charged (96%) last night. Tried to connect to my phone again to check battery charge (70%) and left it on blue tooth for about 10 minutes accidentally. Then, the olive went silent. Tried turning on...nothing. Tried turning on again this morning...nothing. Tried charging again...nothing. Olive support, please HELP!

    0
    Comment actions Permalink
  • Bryan Milton

    Well I've put in the jumper and got the pulsing glow from the olive.
    Soldering in the jumper was reasonably easy on the large solder joint end but the other end took several attempts to get a joint that didn't just fall apart as soon as the wire was moved!

    0
    Comment actions Permalink
  • Gabriele Foddis

    Probabilmente non hai fatto bene la saldatura, riprova.

    You probably did not do the welding well, try it again.

    0
    Comment actions Permalink
  • Bryan Milton

    Like I said, it took me 3 attempts to get a half decent connection one end!
    Not a simple soldering job by any means!

    1
    Comment actions Permalink
  • Gabriele Foddis

    Ma ora funziona bene?

    0
    Comment actions Permalink
  • Erick Uceda

    I just tried the kick ass method both my cradles and it worked though one I took too long to put it on the charger and now it's not charging the device. I'll have to give it another jump start in a few minutes but at least one cradle is charging so that's good news.

    I also had to use a rubber band because one of the taps was broken when it came, thankfully I still have it so I'm planning to superglue it there. 

    0
    Comment actions Permalink
  • Bryan Milton

    Flugerbill, I just tried kick starting the battery as in Ton Weenk's method as well. Only difference is i couldnt be bothered to dismantel the plug so i just pushed some fine wires into it to make the connections to the cr123 charger.
    I tested the battery after 10 seconds and found no output and no heat build up according to my Flir camera so I gave it 30 seconds and tested again, it was reading about 1.75V so I zapped it again for a further two x 30 seconds keeping an eye on it with the heat camera, it was then putting out over 3V so I disconnected the bridge, refitted it into the charger and plugged it in.
    All seems to be working fine, the Olive still had 57% charge from the bridge charging solution after I had done a couple of hearing test/calibrations and when I put it back in the charger the green led started it's slow pulse.

    0
    Comment actions Permalink
  • Rolland Rice

    I'd really like it if you guys came to a determination as to what to do about the non-charging cradles - today! I'm OK with putting in a new battery. I either need you to send me a new battery or give me details on what to order. I'm not going to modify my cradles by soldering a jumper. That seems to me to be not only the most difficult way, but damaging.

    0
    Comment actions Permalink
  • michael a smith

    I considering ordering a replacement battery, to see if i can get started with testing.  

    I've found this and other similar batteries at amazon

    https://www.amazon.com/uxcell-Rechargeable-Lithium-Polymer-Battery/dp/B0767CW5QD/ref=sr_1_4?ie=UTF8&qid=1507828917&sr=8-4&keywords=502030

     

    Will this battery work?

    None of the batteries i have found have this black wire coming out of the battery connecter?  Is this needed?  Will it effect the olive if i get a battery without it?

     

    Also,  Since OU says that the batteries drained past the point of no return, does that mean there is a design flaw or that these batteries just aren't good enough to use for production.  

    What happens if i simply don't use my Olive for a few weeks?   Bricked?

     

     

    0
    Comment actions Permalink
  • Kevin Fitzpatrick

    Michael Smith, also what happens to the battery in the Olive itself???  Was it damaged during transport?

    0
    Comment actions Permalink
  • Ken Cheng

    @Michael, that amazon battery looks to be the same. The other wires coming out, I'm pretty sure, are a thermal sensor in case the charging cradle overheats. You may be able to tease the wires out of the connector and use the original connector. Lift up on the little white clips.

    As I understand it, these lithium batteries have a minimum required charge otherwise you brick them. Usually, products ship without the battery able to drain, but these were not shipped that way, so they drained past the minimum charge level. Some people here have tried to restart the batteries by giving them a jolt. I tried, but it didn't work.

    0
    Comment actions Permalink
  • Ken Cheng

    After reading Flugerbill's method of kickstarting the battery, I tried an XTAR VC4 smart battery charger, and did the same. It took a minute and a half for the readout on the XTAR display to reach 4.1V at 0.8A. About 20mAh. I then reinstalled the battery in my Olive cradle, and now the earpiece pulses, as it should.

    Using the XTAR VC4 charger was nice since I got to watch the display as the voltage ramped up. Like I said, it took alot longer, more than 1.5minutes, for my method to reach 4.1V and 0.8A.

    0
    Comment actions Permalink
  • Mark

    Is there a way to even bypass the battery and use the crade with just a USB charger?
    I could understand not being able to charge off the battery, but if the battery goes bad you cannot charge at all?  That is a very poor design parameter.

    0
    Comment actions Permalink
  • Olive Support Team 2

    Hi everyone,

    We just wanted to add a word of caution for the kick-start method (thanks to Ton Weenk and
    Flugerbill for describing the procedure). If you have the equipment to attempt the procedure (we would recommend a DC variable power supply), only attempt the procedure once. LiPo batteries are known for being quite flammable if not charged/discharged properly. As Tom and Flugerbill noted, (we've verified it) 10 seconds @ 5V 1.00 A, is enough. If you notice any increase on the battery temperature, stop immediately. Attempting this procedure with a battery charger of unknown charging parameters (voltage and current) is not recommend, given the volatility of these batteries when charged/discharged incorrectly.

    Our current plan is to source batteries from suppliers in each respective country to send as replacements, meanwhile we will attempt to verify if this battery available in Amazon is a viable option. 

    We thank you for your continuous support and patience. As always please email us, open a chat below, or comment if you have any additional comments. 

    -Olive Union Support & Engineers

    2
    Comment actions Permalink
  • Olive Support Team 2

    @Mark, you are most certainly correct. It was a design oversight on our part. We will definitely implement a fail-safe method to by-pass the battery if this ever were to occur again. We are also working on a battery over-discharged protection circuit to prevent batteries from depleting completely. 

    1
    Comment actions Permalink

Please sign in to leave a comment.

Powered by Zendesk